站长论坛 - 站长交流社区- SEO交流论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 232|回复: 3

[PHP] require 有问题!

[复制链接]
发表于 2018-9-28 10:38:24 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
我写了一个 .inc 文件,要是和 .php 文件放在一起的话,
就可以 require 上,但是要是放到别的目录如 inc  下就 require 不上!
错误日志是:
[Wed Jan 22 22:02:51 2003] [error] PHP Fatal error:  Failed opening required 'dispcnt.inc' (include_path='/usr/mochou/www/inc') in /usr/mochou/www/index.php on line 2
我在 /usr/local/lib/php.ini 中已经加了
; UNIX: "/path1:/path2"
include_path = ".:/inc:/usr/mochou/www/inc"
之所以加了好几个是因为我不知道应该怎么加,其实绝对路径应该是
/usr/mochou/www/inc
另外 httpd.conf 中的
......
ServerRoot "/usr/local/apache"
......
DocumentRoot "/usr/mochou/www"
.....
Alias /inc/ "/usr/mochou/www/inc/"
;
    AllowOverride None
    Order allow,deny
    Allow from all
;
.....
等等我都已经加了。
我该怎么办?
回复

使用道具 举报

发表于 2019-1-13 14:17:45 | 显示全部楼层
很好啊.谢谢楼主啊
回复 支持 反对

使用道具 举报

发表于 2019-1-15 21:52:29 | 显示全部楼层
高人啊,真是好东西啊!!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|易采站长站 ( 蒙ICP备14002389-1号 ) |

GMT+8, 2019-12-8 02:36

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表